Vẫn là tổng chữ số

View as PDF

Submit solution

Points: 100.00
Time limit: 1.0s
Memory limit: 98M
Input: stdin
Output: stdout

Author:
Problem type
Allowed languages
C, C++, GAS64, Pascal, Perl, PHP, Python, Sed, TCL, Text

Tính số lượng số không lớn hơn ~k~ và có tổng các chữ số là một số nguyên tố.

Giới hạn:

~ 1 \leq k \leq 10^6 ~

Example Input

11

Example Output

5

TEMPLATE

#include <iostream>
using namespace std;

int TinhTongChuSo (int number)
{
    //###INSERT CODE HERE -
}

bool KTSoNguyenTo (int number)
{
    //###INSERT CODE HERE -
}
int main()
{
    int n, res;
    cin >> n;
    res = 0;
    for (int i = 0; i <= n; ++i)
    {
        int tongChuSo = TinhTongChuSo(i);
        if (KTSoNguyenTo(tongChuSo)) res++;
    }
    cout << res;
}


Comments

Please read the guidelines before commenting.


There are no comments at the moment.